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After applying a HotFix OpenEdge Servers do not start

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Information

 
TitleAfter applying a HotFix OpenEdge Servers do not start
URL NameAfter-applying-a-HotFix-OpenEdge-components-do-not-start
Article Number000182363
EnvironmentProduct: OpenEdge
Version: All supported versions
OS: All supported platforms
Question/Problem Description
OpenEdge components do not start after applying an OpenEdge Hotfix.
Related OpenEdge server product log files are not updated
Database does not start after applying OpenEdge Hotfix
Ubrokers do not start as AdminServer fails to start
proadsv -start doesn't error but instantaneously returns back to the command prompt with just the version number.  
The admsrv.log, cmdplugin.log and ads0.exp log files are not touched.  
Steps to Reproduce
Clarifying Information
All OpenEdge components were shutdown before applying the Hotfix
Permissions have been verified on executables
Error Message
Defect Number
Enhancement Number
Cause
The wrong Hotfix was applied to the current OpenEdge install.
Resolution
First download the appropriate Hotfix from ESD for the current install:
 
Progress/OpenEdge [Major version].[Minor version].[Service Pack].[Hotfix].[OS] 

For example:
  • Hotfix 11.5.1.016 for Windows 64-bit OpenEdge 11.5.1 installation: PROGRESS_OPENEDGE_11.5.1.016_WIN_64.zip
  • Hotfix 11.5.1.016 for Windows 32-bit OpenEdge 11.5.1 installation: PROGRESS_OPENEDGE_11.5.1.016_WIN.zip
For further clarification refer to Article:
If in doubt, contact Technical Support to assist you further.

To revert the incorrect HotFix media:

While Windows has been used in the examples below, the same applies for all Operating Systems certified by the OpenEdge version in use.
For further clarification on applying a Hotfix refer to Article:
Option 1: If an installation backup was taken before applying the Hotfix, as advised in the associated Hotfix Readme:
Revert to the copy of the install backup then re-apply the correct Hotfix for the OpenEdge bit version + Service Pack

Option 2: If an installation backup is not available:

1. Uninstall OpenEdge 
2. Reinstall the OpenEdge major-minor version eg: OpenEdge 11.5.0 for Windows 64-bit
3. Reinstall the latest Service Pack if applicable eg: OpenEdge 11.5.1 Service Pack for Windows 64-bit 
4. Apply the appropriate Hotfix eg: OpenEdge 11.5.1.016 Hotfix for Windows 64-bit 
 
Workaround
Notes
Keyword Phrase
Last Modified Date11/20/2020 7:24 AM

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