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AdminServer cannot be started due to virus

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Information

 
TitleAdminServer cannot be started due to virus
URL NameAdminServer-cannot-be-started-due-to-virus
Article Number000176063
EnvironmentProduct: OpenEdge
Version: 10.x, 11.x, 12.x
OS: Windows
Question/Problem Description
AdminServer cannot be started from Services or the proadsv command line

admserv.log reports error locating some schema files like juniper.schema and agent.schema
PROUTIL PROSTRCT RFUTIL utilities report error: Database has the wrong version number.
Steps to Reproduce
Clarifying Information
Replaced some of the files that have been corrupted by the virus from a backup snapshot of the system.
Error Message
Defect Number
Enhancement Number
Cause
DB files and the installation files are all corrupted by a virus.  
Resolution
First ensure that the virus is cleaned from the file server and all mounted filesystems
  1. Reinstall OpenEdge and Restore databases from unaffected backup media
  2. If a backup snapshot of the system is unaffected by the virus, replace all database files and Progress install directory files.
Workaround
Notes
Keyword Phrase
Last Modified Date9/19/2019 4:34 PM

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