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64-bit Windows installs are missing the \bin32 directory.

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Title64-bit Windows installs are missing the \bin32 directory.
URL Name64-bit-Windows-installs-are-missing-the-bin32-directory
Article Number000174814
EnvironmentProduct: OpenEdge
Version: 11.5, 11.6, 11.7, 12.1
OS: Windows 64-bit
Question/Problem Description
OpenEdge 64-bit 11.5, 11.6, 11.7,12.1 installs are missing the \bin32 directory
After installing 11.5 64 bit on Windows 64 bit the DLC\bin directory is missing the \bin32 directory
The \bin32 directory was included in their OE 11.3 64 bit for Windows install.
Missing \bin32 directory on OE 64 bit install and can not find needed Windows 32 bit OBDC drivers.
 
Steps to Reproduce
Clarifying Information
The \bin32 directory was present in earlier Windows OpenEdge 11.4 11.3 11.2 11.1 11.0 64-bit installations to use both 32-bit and 64-bit ODBC drivers.
Error Message
Defect Number
Enhancement Number
Cause
Changes with OpenEdge 11.5 +, which allow for 32 and 64 bit Progress installations on the same Windows 64 bit server, resulted in the removal of the \bin32 directory in OE 64 bit installations.  This was by design and is not a defect.
 
Resolution
Since OpenEdge 11.5 and later, Progress will install only the ODBC driver for the OE platform being installed:
  • 32-bit OE installs only the 32-bit ODBC driver,
  • 64-bit OE installs only the 64-bit ODBC driver.
Customers who require both 32-bit and 64-bit ODBC drivers will be able to install the SQL Client Access product for the missing platform support in order to obtain the other 32 or 64 bit ODBC driver.  For further information refer to Article:
 
Workaround
Notes
References to Other Documentation:

Progress Article(s):
 Can the same version of 32-bit and 64-bit products be installed on the same Windows machine?    
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Last Modified Date11/20/2020 6:52 AM

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