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Certain clients terminate with error 6028

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Information

 
TitleCertain clients terminate with error 6028
URL Name000055700
Article Number000170968
EnvironmentProduct: OpenEdge
Version: All supported versions
OS: Windows
Question/Problem Description
At only a few locations, users of a widely used application receive error "A/R block doesn't match callers. (6028)" when their session terminates.

The problem did not always occur, but has appeared within the last few months.

The problem occurs intermittently several times per week, but is not readily reproducible.

The code identified in the protrace uses a temp-table.
Steps to Reproduce
Clarifying Information
Machines on which the error occurs have the recommended amount of memory to run the application.

No shared temp-tables.

No other local procedures are updating the temp-table at the time the error occurs.
 
Error Message
Defect Number
Enhancement Number
Cause
The OpenEdge working directory or directory defined in the -T client startup parameter, was not excluded from the antivirus program at the sites where the problem occurred.
The 6028 error in this case was due to the a/r unit (block) which acts as place holder in the lbi file for a subtransaction not being where it is expected to be.
The antivirus program was accessing LBI client temp files files that interfered with normal temp-table processing.
Resolution
Exclude OpenEdge and application directories from the antivirus program.

Refer to Article   What Progress files could be excluded from an anti-virus program?

 
Workaround
Notes
Progress Articles:  

 How to troubleshoot error 6028   
 
Keyword Phrase
Last Modified Date11/20/2020 7:31 AM

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