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ActiveMQ port 6835 is binding to the wrong IP address on a multi-NIC machine

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Information

 
TitleActiveMQ port 6835 is binding to the wrong IP address on a multi-NIC machine
URL Name000055403
Article Number000170740
EnvironmentProduct: OpenEdge
Version: 11.3, 11.4
OS: Windows
Other: OEM/OEE
Question/Problem Description

ActiveMQ port is binding to the wrong IP address on a multi-NIC machine
AdminServer also binds to the wrong IP address
AdminServer is binding to the correct IP address using the article 000012638
 

Steps to Reproduce
Clarifying Information
AdminServer is binding to the correct IP address using the article 000012638
pinging the remote AdminServer machine from the OEM machine shows the correct IP address which is forced bind to the AdminServer using above article
pinging from the localhost using the machine name shows wrong IP address, i.e, not the one AdminServer is force bound to
 
Error Message
Defect Number
Enhancement Number
Cause
All of the three NIC cards have the "Automatic Metric" checked on.  Thus, when "route print" command is used on the command prompt, it shows the same metric for all three NICs.  This caused the wrong IP to be used when ping'd from the localhost using the server name as that IP is the first one listed on the "route print" report. Read more about automatic metric feature at http://support.microsoft.com/kb/299540 .

 
Resolution
Steps to change the Metric value:

1. Double click on the correct Network Adapter in the Control Panel\Network and Internet\Network Connections
2. Click on the properties > Select Internet protocol Version 4 (TCP/IPv4) > Click on the Properties
3. Click on the Advance button at the bottom of the General tab
4. Uncheck Automatic metric and type the value for the Interface metric to the lower value than the one shown in the "route print" report for all NIC's Internet protocol configuration.  The lowest possible value is 5 according the Microsoft article http://support.microsoft.com/kb/299540 .
5. Click OK out of the configuration.
6. ping the server name from command prompt from the localhost which will show the correct IP address now.
7. Restart the AdminServer.  

Using the above fix would not require forcing AdminServer to bind specific ip as it would now be directed to the correct IP address.

If the fix on the NIC is not possible, use the workaround in the workaround section below.
Workaround
Force the ActiveMQ port (default 6835) to bind to specific IP address using the article 000055400 .
Notes
Keyword Phrase
Last Modified Date11/20/2020 7:31 AM

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