Salesforce

OpenEdge Adminservice do not always get started with a new reboot of a Windows server

« Go Back

Information

 
TitleOpenEdge Adminservice do not always get started with a new reboot of a Windows server
URL Name000051948
Article Number000192494
EnvironmentProduct: OpenEdge
Version: All supported versions
OS: Windows
Question/Problem Description
OpenEdge AdminService do not always get started with a new reboot of a Windows server

OpenEdge AdminService is not started with the standard 'Local System' Windows system account but with a Windows Domain account

The Windows Domain account is granted the specific additional Windows rights needed as described in Article:
Steps to Reproduce
Clarifying Information
    The OpenEdge AdminService is configured to autostart the option 'Automatic (Delayed Start)'
    Error Message
    Defect Number
    Enhancement Number
    Cause
    The OpenEdge AdminService (service) tried to start while the other Windows services that needed to authenticate the Windows Domain user used were not started yet.
    Resolution
    Add Service dependencies to the OpenEdge AdminService (service) to ensure that it will only try to start after the other needed Windows Network related services have initialised.

    When using the standard 'Local System Account' this is not needed as the local system account is always reachable. 
     
    To add Service dependencies the following command can be used:
     
    sc config AdminService11.7 depend= TermService/Netlogon/Dhcp/Dnscache/nsi/lmhosts/LanmanWorkstation/WebClient    

    For further detail refer to Article:
    Workaround
    Notes
    Keyword Phrase
    Last Modified Date10/2/2020 12:27 PM

    Powered by