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Database activity drops suddenly when clients HANGUP

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Information

 
TitleDatabase activity drops suddenly when clients HANGUP
URL Name000035040
Article Number000163418
EnvironmentProduct: OpenEdge
Version: 10.x, 11.x
OS: All Supported Operating Systems
Question/Problem Description
Database activity stops drops suddenly.
Database OLTP hangs occur intermittently.

All the clients sessions stop responding.

PROMON detects a minimum of activity.

From a transactional standpoint, active transactions are hung.  
Clients are blocked on specific record ids.  
Some clients are also blocked on TXEC, TXES etc.   
Focusing on the blocked clients, the locked buffers show which user / PID has the resource that the others are waiting on.  In these cases, the users that have what the others appear to be blocking waiting for, are also hung on a latch possibly for a buffer.  
Stack traces against the hung clients all show varying degrees of waiting (latSleep, utnap, nanaosleep, nsleep,   latWaitOnSem, latUsrWait, bmblkwait. etc)
New client sessions can login to the database, but their application sessions immediately freeze.
Steps to Reproduce
Clarifying Information
PROMON and VST's can be read at this time.

ABL   101: (452)   Login by <user> on <tty>
ABL   101: (-----) vv_flush:I/O error 5 on fd 1
ABL   101: (562)   HANGUP signal received.

No logout after the HANGUP.

Stack trace from _progres reads:

_p_nsleep
nsleep
nanosleep
utnap@AF12_8
latSleep
latObjLatchLock
lkrend
lkresync@AF12_4
dbenvout@AF17_11
dbUserDisconnect
dsmUserReset
dbrsy
prorsy
fdrsy
drSigClient
drSigDo1
drSigDispatch
<signal>
_check_lock
lkrestore
dblkrst
dbnxt1
dbnxt
profnd
fdfnd
bfFindRow
rnbfnxtDoit
rnbfnxtBody
rnbfnxt
rnexec_entry
rninterpret
umeDispatchEvent
wvRunDispatcher
iodispatch
rnrq
main
__start
Error Message
Defect NumberDefect PSC00246188 / OE00223147
Enhancement Number
Cause
A user session was holding a latch when it received HANGUP signal and self deadlocked on that latch then processed an abnormal disconnect due to the hang-up, leaving latches held which other users are blocked on.
Resolution
Upgrade to OpenEdge 10.2B08, 11.3.0.0 or later. Where the problem of the process not in service when executing a critical session on the object latches has been addressed.
Workaround
Restart the database.
Notes
Keyword Phrase
Last Modified Date11/20/2020 7:34 AM

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